Back to overview
Resolved

Slow product load performance

Sep 14, 2026 at 12:35pm UTC
Affected services
Phaselab Product - UK Region

Resolved
Sep 14, 2026 at 1:15pm UTC

We have deployed a fix and the issue is resolved.

Updated
Sep 14, 2026 at 1:04pm UTC

We have deployed a permanent fix and are monitoring rollout. Customers are reporting improved loading performance.

Updated
Sep 14, 2026 at 12:51pm UTC

We have identified the root cause and have mitigated impact. We are starting to see improved peroformance but are working on a permanent fix which should go live shortly.

Created
Sep 14, 2026 at 12:35pm UTC

We are currently investigating reports of slow load times for customers hosted in the UK (eu-west-2) region.